f> SR9C Failure to load 2nd round - Ruger Forum

Ruger Forum

SR9C Failure to load 2nd round

This is a discussion on SR9C Failure to load 2nd round within the Ruger Pistols forums, part of the Pistol & Revolver Forum category; After firing 550 rounds through my 9C, it quit loading second round and slide would stay open. Called Ruger explained problem, they sent me a ...


Go Back   Ruger Forum > Pistol & Revolver Forum > Ruger Pistols

Reply
 
LinkBack Thread Tools Display Modes

Old April 29th, 2014, 12:34 PM   #1
 
Join Date: Feb 2012
Location: kansas
Posts: 9
radpilot is on a distinguished road
SR9C Failure to load 2nd round

After firing 550 rounds through my 9C, it quit loading second round and slide would stay open.
Called Ruger explained problem, they sent me a prepaid shipping label and RA number.
Shipped it last Monday and received it back this Monday.
They replaced a part and fired 40 rounds with no problems.

Great customer service!!



radpilot is offline  
Advertisements
Old April 29th, 2014, 04:58 PM   #2
 
Join Date: Apr 2014
Location: kansas
Posts: 44
thumper68 is on a distinguished road
I am glad that they took care of it for you. I hear great things regarding their customer service. Did the h say what part they replaced? I also have a new sr9c.
thumper68 is offline  
Old April 29th, 2014, 06:30 PM   #3
 
Join Date: Jan 2014
Location: Morris, Illinois
Posts: 51
trustingodman is on a distinguished road
glad they fixed it up for you
trustingodman is offline  
 
Old April 29th, 2014, 08:06 PM   #4
 
Join Date: Jun 2013
Location: Tennessee
Posts: 99
jhc37013 is on a distinguished road
Quote:
Originally Posted by radpilot View Post
After firing 550 rounds through my 9C, it quit loading second round and slide would stay open.
Called Ruger explained problem, they sent me a prepaid shipping label and RA number.
Shipped it last Monday and received it back this Monday.
They replaced a part and fired 40 rounds with no problems.

Great customer service!!
Sounds like it could be the slide stop spring came off, what date was yours inspected? I had the same problem and so have others I would like to try and pin point a time frame these where manufactured, from what I have read so far it is typically around spring/summer 2013.
jhc37013 is offline  
Old April 29th, 2014, 08:38 PM   #5
Spellign Bee Champ
 
alayonruger's Avatar
 
Join Date: May 2013
Location: Moonbeam's Paradise
Posts: 14,306
alayonruger has much to be proud ofalayonruger has much to be proud ofalayonruger has much to be proud ofalayonruger has much to be proud ofalayonruger has much to be proud ofalayonruger has much to be proud ofalayonruger has much to be proud ofalayonruger has much to be proud ofalayonruger has much to be proud of
Glad they took care of you.
Did you learn what they replaced? It would help us other SR9C owners.
alayonruger is offline  
Old April 30th, 2014, 05:51 AM   #6
 
Join Date: Jan 2013
Location: Southern Illinois
Posts: 3,154
GJHIII is on a distinguished road
I've had this problem with just about every 9mm that I've shot, irregardless of brand. Each and every time it has been the feed ramp. Clean and polish the ramp and the problem goes away. Sometimes with as few as 100 rounds.
Hope this helps.
GJHIII is offline  
Old April 30th, 2014, 06:39 AM   #7
 
Redleg's Avatar
 
Join Date: Mar 2011
Location: Huntington Beach, CA
Posts: 3,826
Redleg will become famous soon enoughRedleg will become famous soon enough
Quote:
Originally Posted by GJHIII View Post
I've had this problem with just about every 9mm that I've shot, irregardless of brand. Each and every time it has been the feed ramp. Clean and polish the ramp and the problem goes away. Sometimes with as few as 100 rounds.
Hope this helps.
When you say "polish" the ramp, how do you do that?
Redleg is offline  
Old May 1st, 2014, 06:03 AM   #8
 
Join Date: Jan 2013
Location: Southern Illinois
Posts: 3,154
GJHIII is on a distinguished road
Quote:
Originally Posted by Redleg View Post
When you say "polish" the ramp, how do you do that?
For me, a little Mothers Mag and a couple Q-Tips have always done the job. I've seen others get their files, sandpaper, Dremel tool and buffing wheel out for the "polish". But they usually end up having to replace the barrel and ramp, if they can find one. And sometimes end up with another paper weight.
GJHIII is offline  
Old May 1st, 2014, 07:47 AM   #9
 
Join Date: Nov 2011
Location: iowa
Posts: 996
tarza is on a distinguished road
To polish the feed ramp.I took some metal polish and a paper towel and just rubbed it with my finger for 5 min. Just long enough to make the ramp shiny and slick. No more than that. Or you can just shoot it a couple 100 times.
tarza is offline  
Old May 1st, 2014, 08:43 AM   #10
 
GunLover's Avatar
 
Join Date: Aug 2011
Location: Alabama
Posts: 1,324
GunLover will become famous soon enough
Quote:
Originally Posted by GJHIII View Post
I've had this problem with just about every 9mm that I've shot, irregardless of brand. Each and every time it has been the feed ramp. Clean and polish the ramp and the problem goes away. Sometimes with as few as 100 rounds.
Hope this helps.
While I do like to polish the feed ramps on my guns, I doubt it was the cause of the slide locking back after a shot. Did you read the original post completely or just the subject line?
GunLover is offline  
Old May 1st, 2014, 09:56 AM   #11
 
mndoggie's Avatar
 
Join Date: Aug 2010
Location: MN
Posts: 3,948
mndoggie is a jewel in the roughmndoggie is a jewel in the roughmndoggie is a jewel in the rough
Quote:
Originally Posted by GJHIII View Post
For me, a little Mothers Mag and a couple Q-Tips have always done the job. I've seen others get their files, sandpaper, Dremel tool and buffing wheel out for the "polish". But they usually end up having to replace the barrel and ramp, if they can find one. And sometimes end up with another paper weight.
I must be the exception.

I never really had a feed issue due to a rough ramp, but I like the polished ramp look.

I've used a dremel tool to polish the feed ramps on all my pistols and never had to replace anything.
mndoggie is offline  
Reply

  Ruger Forum > Pistol & Revolver Forum > Ruger Pistols


Search tags for this page

ruger sr40c failure to load

Click on a term to search for related topics.

Thread Tools
Display Modes


Similar Ruger Forum Discussions
Thread Thread Starter Forum Replies Last Post
SR9c 9mm failure to chamber a round pfllewis Ruger Pistols 9 April 13th, 2014 07:44 AM
Failure to Load SR9c Breymac Ruger Pistols 5 February 23rd, 2014 11:57 AM
Failure to fire every 3rd or 4th round 30cal Ruger 10/22 Rimfire 10 June 14th, 2012 04:19 PM
22/45 failure to chamber a round mgcnewhampshire Ruger Rimfires 0 March 31st, 2012 04:51 PM
failure to feed on the last round coronel Ruger Pistols 22 October 22nd, 2007 01:57 PM

Top Gun Sites Top Sites List
Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1
Copyright © 2006 - 2017 Ruger Forum. All rights reserved.
Ruger Forum is a Ruger Firearms enthusiast's forum, but it is in no way affiliated with, nor does it represent Sturm Ruger & Company Inc. of Southport, CT.